intra-mart Accel Platform 2021 Summer(Cattleya) リリースノート 初版 2021-08-01

6. システム要件

当バージョンにおけるシステム要件は次の通りです。

注意

NTTデータイントラマート社の責任(サポート)範囲について 「製品保守ポリシーとアップデート・パッチの考え方」 - 「intra-mart製品と周辺ミドルウェアの責任範囲」 を参照してください。

6.1. サーバ要件

種別 製品名
OS
Windows Server 2012 (64bit)

Windows Server 2012 R2 (64bit)

Windows Server 2016 (64bit)

Windows Server 2019 (64bit)

Red Hat Enterprise Linux 7.x (64bit)

Red Hat Enterprise Linux 8.x (64bit)

Amazon Linux 2
ハードウェア
各OSの安定稼動が可能となるPC

(CPU 3GHz以上を推奨)
クラウドサービス
Amazon Elastic Compute Cloud (Amazon EC2)

Microsoft Azure Virtual Machines

Oracle Java Cloud Service / Oracle Database Cloud
必要メモリ容量(JVM) 推奨する最小構成 4GB 以上
必要ディスク容量 1GB 以上(intra-mart Accel Platformのみ)
JDK
・ Resin の場合

Oracle JDK 8
Oracle JDK 11
OpenJDK 11 (Red Hat製)
Amazon Corretto 11

・ Payara

Oracle JDK 11
OpenJDK 11 (Red Hat製)
Amazon Corretto 11

・ Oracle WebLogic Server 12c R2(12.2.1) の場合

Oracle JDK 8

・ WebSphere Application Server 9.0.5 の場合

IBM SDK 8

 ※OSとの組み合わせはJDKベンダー各社がサポートしているOSである事が前提です。

Web Application Server
Resin 4.0.65

Payara Server Enterprise

WebSphere Application Server 9.0.5

Oracle WebLogic Server 12c R2(12.2.1)
データベース
Oracle Database 12c Release 2

Oracle Database 19c

PostgreSQL 9.6

PostgreSQL 10

PostgreSQL 11

PostgreSQL 12

PostgreSQL 13

Microsoft SQL Server 2012

Microsoft SQL Server 2014

Microsoft SQL Server 2016

Microsoft SQL Server 2017

Microsoft SQL Server 2019
データベース (クラウドサービス)
Amazon RDS for Oracle Database

Amazon RDS for PostgreSQL

Amazon Aurora PostgreSQL-Compatible Edition
Web Server
Internet Information Services 8 (Windows Server 2012)

Internet Information Services 8.5 (Windows Server 2012 R2)

Internet Information Services 10.0 (Windows Server 2016)

Internet Information Services 10.0 (Windows Server 2019)

Apache HTTP Server 2.4(DSO サポート版)

IBM HTTP Server 9 (WebSphere Application Server 9.0.5)
LDAP Server

(LDAP認証利用時のみ)
LDAP v2 , v3
IM-Juggling

バージョン:1.0-20210531
OS(日本語、中国語、英語OS)

Windows Server 2012 (64bit)

Windows Server 2012 R2 (64bit)

Windows Server 2016 (64bit)

Windows Server 2019 (64bit)

Windows 10 デスクトップ (64bit)

Java Platform, Standard Edition Runtime Environment 8 ( IM-Juggling に同梱)
※同梱されたJRE8は IM-Juggling のみで利用します。

警告

Resin は「プロダクトファイルダウンロード」からダウンロードしたものを動作保証対象とします。
上記サイト以外からダウンロードした Resin では正常に動作しません。

警告

運用環境でのご利用は、必ずWeb Serverを経由してWeb Application Serverへ接続してください。
静的コンテンツは、必ずWeb Serverに配置することが条件です。
これに該当しない接続の場合は、動作保証外(サポートの対象外)です。
Resin の httpd機能は、開発(e Builder)用です。

警告

Microsoft SQL Serverは、性能・パフォーマンスに関する問い合わせが数多く報告されています。十分な検証とチューニングが必要です。

注意

IBM製品(WebSphere Application Server)をご検討の場合は事前に弊社までご相談ください。

注意

非公開のスタイルまたは、APIは推奨されません。これらは予告なく削除される可能性があります。

APIドキュメント等に公開されていないスタイルまたは、APIは利用しないでください。
将来、予告なく削除される場合があります。

注意

次の Web Application Server と データベース の組み合わせは動作保証外(サポートの対象外)です。
Web Application Server
WebSphere Application Server 9.0.5
Oracle WebLogic Server 12c R2(12.2.1)
データベース
Microsoft SQL Server
Microsoft SQL Server

注意

SAP HANAにJDBCで接続する場合、シェアドデータベースとしての利用以外は動作保証外(サポートの対象外)です。

注意

TERASOLUNA Server Framework for Java (5.x) for Accel Platform は、Microsoft SQL Server には対応していません。

注意

Oracle Database 12c Release 2 において、COMPATIBLEの設定は動作保証外(サポートの対象外)です。

注意

コンテナ環境のご利用について

intra-mart Accel Platform は アプリケーションサーバ上で動作するWebアプリケーションです。
コンテナ環境での運用については、リソースの節約、システム構成を容易に変更できる等多くのメリットもありますが、コンテナ管理は十分に設計を行う必要があります。
製品サポートの対象は、アプリケーションの範囲であるため、コンテナ運用の範囲(ネットワーク構成、データ保護、コンテナの配置(オーケストレーション)等)については対象外です。

コラム

セットアップ済の IM-Juggling ツールのバージョンの確認は、ツールバー icon_juggling (このアプリケーションに関して)をクリックします。
ポップアップで表示される左下にバージョン番号が表示されます。
2021-08-01 現在の最新バージョンは、「 1.0-20210531 」です。

コラム

セットアップ済の IM-Juggling ツールのバージョンの確認は、ツールバー icon_juggling (このアプリケーションに関して)をクリックします。

6.1.1. 特定機能の利用時に必要となるサーバ要件

  • IMBox を利用する場合
  • IM-ContentsSearch for Accel Platform を利用する場合

6.1.2. 文字コード

intra-mart Accel Platform 、および、Accel シリーズのアプリケーション全ての文字コードは UTF-8 のみです。

注意

他システム連携等により、UTF-8以外の文字コードを利用したい場合、データベースのみSJISとして利用する事が可能です。
過去の事例では、Oracleデータベースにおいて JA16SJISTILDE での動作実績があります。

ただし、次の制約があります。
・弊社では原則、UTF-8でのサポートです。お客様自身で動作検証を行って頂く必要があります。
・既存機能、または、将来的なアップデート・機能追加によって正常に動作しない可能性があります。この場合、弊社では対応、および、責任について負いかねます。
・弊社サポートへのお問合せは、お客様側で事前に文字コードに起因する問題かの切り分け・原因調査を含む作業をお願いする、条件付きサポートです。

6.2. クライアント要件

種別 ハードウェア OS ブラウザ クライアントタイプ
PC PC/AT 互換機 Windows 10

Internet Explorer 11

Microsoft Edge 91以上

Google Chrome 91以上

[PC]

[PC]

[PC]

Mac macOS Catalina Google Chrome 91以上 [PC]
スマートフォン

iPhone端末

iPad端末

Android端末

iOS 13 / iOS 14

iPadOS 13 / iPadOS 14

Android 8.0以上

Safari

Safari

Google Chrome

[SP]

[PC(一部制限あり)・SP]

[SP]

警告

各ベンダより提供される、サーバ・クライアント製品のサポート終了に伴う、弊社製品の対応方針について

下記を参照してください。

Microsoft Windows 10 については、マイクロソフト社が公式にサービスを終了するバージョンはサポート対象外です。

コラム

クライアント端末は64bitのみ動作可能です。

警告

Adobe Flash Player は 2020/12/31 にサポート終了が発表されています。下記画面のご利用については、 弊社の「 FAQサイト」でご確認ください。

次の機能はFlashで画面が作成されています。
利用端末に Adobe Flash Player 32以上がインストールされている必要があります。
・ViewCreator - 2017 Spring(Portland)以前の「クエリ編集」画面
・アプリケーション共通マスタ(互換) - 「商品マスタ設定」各画面
・richtextarea(非推奨タグライブラリ)

注意

クライアント要件に記載されているOSとブラウザ以外の組み合わせはサポートされません。
例えば次の組み合わせはサポートの対象外です。注意してください。
・Windows Server 2012 R2 + Internet Explorer 11(サーバOS上のブラウザ利用) など

注意

クライアントブラウザは標準モードのみがサポート対象です。
例として、Internet Explorer の「互換モード」、「エンタープライズモード」はサポート対象外です。

注意

Internet Explorer 11 は、更新バージョン 11.0.4(KB2925418) 以上の必要があります。

注意

PC端末におけるブラウザ画面内の操作は、キーボード入力、マウスクリックが対象です。

マルチタッチ/ペン入力対応のディスプレイによる、タッチ入力とペン入力は利用できません。
一部コンポーネントが正常に動作しません。

注意

2021-08-01 現在、iOSをサポートするバージョンは、iOS13 iOS14です。
最新のiOSバージョンについては、下記を参照してください。

注意

Android端末は機種やブラウザの種類によって正常に動作しない場合があります。
弊社のサポート対象は、Google Chrome です。Google Chrome 以外のブラウザでは動作保証しておりません。

注意

Androidタブレットはクライアント要件には含まれません。

注意

iPad端末のSafariは、一般ユーザ向け画面のみ動作保証しています。
認可設定、IM-共通マスタ メンテナンス画面などの管理者向けの画面は動作保証しておりません。

6.2.1. 特定機能の利用時に必要となるクライアント要件

  • IM-Noticeを利用する場合

    種別
    OS
    PC
    Windows 10

    必要なコンポーネント
    Visual C++ 2010 ランタイム ライブラリ (x86)
    Microsoft .NET Framework 4.5.1 (x86 および x64)
    iOS
    intra-mart Accel Platformのクライアント要件に準拠
    Android
    intra-mart Accel Platformのクライアント要件に準拠

  • 多要素認証機能を利用する場合

    種別
    OS
    iOS
    intra-mart Accel Platformのクライアント要件に準拠
    必要なアプリケーション
    Google Authenticator 3.0.2
    Android
    intra-mart Accel Platformのクライアント要件に準拠
    必要なアプリケーション
    Google Authenticator 5.00

  • 互換モジュール ドキュメントワークフロー(BPW)のワークフローデザイナを利用する場合

    種別
    OS
    JRE
    PC
    Windows 10 (32bit)
    Java Platform, Standard Edition Runtime Environment 8 update 20(32bit)以前

    コラム

    ワークフローデザイナを利用するクライアントのみ32bit OSで動作が可能です。​

  • 統合Windows認証モジュールを利用する場合

    種別
    OS
    ブラウザ
    PC
    Windows 10
    Internet Explorer 11
    Microsoft Edge 91以上